Setting Up LWJGL with JCreator

From LWJGL
Jump to: navigation, search

IMPORTANT: Some of the images and/or content on this page is outdated, but should still prove to be useful. If you use JCreator, please update this page.


  1. Create project. Go to Project->Project Properties, select Required Libraries tab and click New.
    • JCreator1.jpg

  2. Call new library collection LWJGL. Click add->path and add the path to where you installed lwjgl. Then click add->Archive again and go to the jar folder and then select lwjgl.jar, lwjgl_util.jar, and jinput.jar.
    • JCreator2.jpg

  3. Make sure the LWJGL library is ticked.
    • JCreator3.jpg

  4. Finally, go to Configure->Options->JDK Tools->Run Application. Then add a new tool and edit the text to be the following, replacing what is in bold appropriately: